Vendor: CAST Category: Video Processing

Hardware RTP Stack for H.264 Stream Encapsulation

Implements a Real Time Transport Protocol (RTP) hardware stack that encapsulates H.264/NAL streams to RTP packets that are compli…

Overview

Implements a Real Time Transport Protocol (RTP) hardware stack that encapsulates H.264/NAL streams to RTP packets that are compliant with RFC 3894 and RFC 6184. 

The H2642RTP can be directly connected to the output of an H.264 encoder to output RTP packets, which can subsequently be forwarded for UDP/IP or TCP/IP encapsulation. The hardware stack produces complete RTP packets, without the need for any host-processor assistance. Along with CAST’s UDP/IP hardware stack, the H2642RTP core is ideal for offloading the demanding task of RTP/UDP/IP encapsulation from a host processor, and enables H.264 video streaming even in processor-less SoC designs. 

The core is easy to integrate in systems with or without a host processor. H.264 stream and RTP packet data are input/output via dedicated streaming-capable interfaces, enabling direct connection to hardware video encoders and hardware stacks for UDP or TCP. Status and control registers are accessible by an AXI4-Lite interface. 

The H2642RTP core is available in RTL source or as a targeted FPGA netlist. Platforms integrating the core along with an H.264 encoder, UDP/IP, and eMAC cores, are also available from CAST, and can enable rapid development of video over IP systems.
 

Key features

  • RTP Encapsulation for H.264 NAL Streams
    • Compliant to RFC 3984 and RFC 6184
    • Enables control of RTP packet size
      • Supports NAL Unit Fragmentation
      • Run-time programmable maximum stream bytes per RTP packet
    • NAL units transmitted in NAL unit decoding order
  • Easier Integration for Faster Development
    • Processor-less, standalone operation
    • AMBA® - AXI Interfaces
      • AXI4-Lite Control/Status register interfaces
      • AXI4-Streaming interfaces for packet data
    • Available pre-integrated with:
      • H.264 Video Encoder cores from CAST
      • UDP/IP Hardware Stack from CAST
      • CAST, Intel, Xilinx, or other third-party eMAC core

Block Diagram

Specifications

Identity

Part Number
H2642RTP
Vendor
CAST
Type
Silicon IP

Compute

Codec Standard
H.264 / AVC

Files

Note: some files may require an NDA depending on provider policy.

Provider

HQ: USA

Learn more about Video Processing IP core

Moving to AMBA® 5? Your AMBA® 4 IP Can Still Come With You

As SoC architectures adopt AMBA® 5 fabrics and components, many proven IP blocks still rely on AMBA® 4 or earlier interfaces. That creates a common integration problem: how do designers connect newer AMBA® 5 system components to existing IP without redesigning the IP or replacing verified blocks?

Frequently asked questions about Video Processing IP

What is Hardware RTP Stack for H.264 Stream Encapsulation?

Hardware RTP Stack for H.264 Stream Encapsulation is a Video Processing IP core from CAST listed on Semi IP Hub.

How should engineers evaluate this Video Processing?

Engineers should review the overview, key features, supported foundries and nodes, maturity, deliverables, and provider information before shortlisting this Video Processing IP.

Can this semiconductor IP be compared with similar products?

Yes. Buyers can compare this product with similar semiconductor IP cores or IP families based on category, provider, process options, and structured technical specifications.

×
Semiconductor IP