Vendor: Rambus, Inc. Category: Hash / MAC

Standalone stateful hash-based signatures software library

The SHSlib is a standalone stateful hash-based signatures software library, which provides signature verification for stateful ha…

Overview

The SHSlib is a standalone stateful hash-based signatures software library, which provides signature verification for stateful hash-based signatures.

SHSlib implements SHA-256 operation in software and has hardware integration with the EIP-120. In addition, it can be integrated with another hardware SHA core for acceleration.

The library is optimized for minimal footprint and stack usage, and it is designed to be hardware and OS agnostic.

Key features

  • Fast and minimal LMS and XMSS software library
  • Bare-metal, no OS nor HW dependencies
  • Hardware acceleration option for SHA-256
  • Single API for both HW and SW
  • Support for integrating third-party SW or HW SHA-256 implementation
  • Written in clear, highly portable C source code
  • Engineer-level support and regular updates provided under maintenance
  • Specifications
    • RFC 8391: XMSS: eXtended Merkle Signature Scheme
    • RFC 8554: LMS: Leighton-Micali Hash-Based Signatures
    • NIST SP 800-208 – Recommendation for Stateful Hash-Based Signature Schemes
    • RFC 6234: US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)
  • Supported Parameter Sets:
    • LMS:
      • LMS_SHA256_M32_H10
      • LMS_SHA256_M32_H15
      • LMS_SHA256_M32_H20
      • LMOTS_SHA256_N32_W4
    • XMSS:
      • XMSS-SHA2_10_256
      • XMSS-SHA2_16_256
      • XMSS-SHA2_20_256
  • Use Cases
    • Secure boot
    • Firmware update
    • No OS, resource constrained environment
    • Quantum Safe requirements for above

Specifications

Identity

Part Number
antum Safe IPsec Toolkit
Vendor
Rambus, Inc.
Type
Silicon IP

Files

Note: some files may require an NDA depending on provider policy.

Provider

HQ: USA

Learn more about Hash / MAC IP core

Beyond Trusted: What the NSA’s New Guidance Means for Hardware Security

On August 25, 2026, the National Security Agency (NSA) released two technical reports addressing intentional threats to application-specific integrated circuits during design and manufacturing: the “ASIC Best Practices Threat Catalog” and “Application Specific Integrated Circuit Level of Assurance 1 (LoA1) Best Practices”.

Frequently asked questions about Hash / MAC IP cores

What is Standalone stateful hash-based signatures software library?

Standalone stateful hash-based signatures software library is a Hash / MAC IP core from Rambus, Inc. listed on Semi IP Hub.

How should engineers evaluate this Hash / MAC?

Engineers should review the overview, key features, supported foundries and nodes, maturity, deliverables, and provider information before shortlisting this Hash / MAC IP.

Can this semiconductor IP be compared with similar products?

Yes. Buyers can compare this product with similar semiconductor IP cores or IP families based on category, provider, process options, and structured technical specifications.

×
Semiconductor IP