Vendor: EnSilica Category: Symmetric Crypto

Combined ChaCha20 and Poly1305 core

The eSi-CHACHA20-POLY1305 core is an easy to use APB hardware accelerator peripheral that is fully compliant with the IETF RFC753…

Overview

The eSi-CHACHA20-POLY1305 core is an easy to use APB hardware accelerator peripheral that is fully compliant with the IETF RFC7539 standard

Poly1305, along with the CHACHA20 encryption algorithm, has been specified for use in the TLS protocol, within RFC7905.
 

Key features

  • Multiple processing modes:
    • Poly1305 key generation based on ChaCha20
    • ChaCha20 stream cipher
    • Poly1305 authentication
    • Additional Authentication Data (AAD)
    • Composite Chacha20-Poly1305 processing for Authenticated Encryption with Associated Data (AEAD)
  • Chacha20 processing of 64-bytes in as low as 13 clock cycles
  • Poly1305 processing of 16-bytes in as low as 4 clock cycles
  • Different processing architectures offering different balances between throughput/area
  • AMBA 3 AHB slave interface for configuration and burst data transfers to perform processing
  • Verilog 2001

Benefits

  • Easy integration into Arm or other microprocessor SoC
  • Small size and high performance

Applications

  • Transport Layer Security (TLS)
  • OpenSSH
  • IPsec
  • Ultra-low power embedded web-serverss

What’s Included?

  • RTL
  • Testbench
  • Software libraries

Specifications

Identity

Part Number
eSi-CHACHA20-POLY1305
Vendor
EnSilica
Type
Silicon IP

Security

Crypto Algorithm
Chacha20

Provider

HQ: UK

Learn more about Symmetric Crypto IP core

Why user-terminal silicon will shape LEO’s next phase

As Low Earth Orbit (LEO) satellite networks target mass-market broadband, mobility and enterprise services, the chipset inside the user terminal – not only the constellation in orbit –will determine the achievable cost, power consumption and production scale

EnSilica: Automotive Manufacturing and Supply Contract Win

EnSilica plc , a leading fabless microchip maker with a growing portfolio of reusable IP, serving the Space & Comms, Industrial, Automotive and Healthcare markets, is pleased to announce a new 7 year manufacturing and supply contract to produce an Arm based sensing chip for a German manufacturer of automotive components.

EnSilica selected for UK CHERI Adoption Collective

EnSilica is pleased to announce its participation in the newly formed CHERI Adoption Collective, launched by PA Consulting in collaboration with the Department for Science, Innovation & Technology (“DSIT”).

Frequently asked questions about Symmetric Cryptography IP cores

What is Combined ChaCha20 and Poly1305 core?

Combined ChaCha20 and Poly1305 core is a Symmetric Crypto IP core from EnSilica listed on Semi IP Hub.

How should engineers evaluate this Symmetric Crypto?

Engineers should review the overview, key features, supported foundries and nodes, maturity, deliverables, and provider information before shortlisting this Symmetric Crypto IP.

Can this semiconductor IP be compared with similar products?

Yes. Buyers can compare this product with similar semiconductor IP cores or IP families based on category, provider, process options, and structured technical specifications.

×
Semiconductor IP